Verified Commit d4a310e2 authored by A. Wilcox's avatar A. Wilcox

Install: Flesh out actual requirements

parent 17f64dd0
......@@ -6,12 +6,12 @@
On a Macintosh, choose <guimenuitem>About This Mac</guimenuitem> from the <guimenu>Apple</guimenu> menu, and then choose <guibutton>System Report</guibutton> or <guibutton>More Info</guibutton>.
</para>
<section id="cpu">
<title>Processor Type/Speed</title>
<title>Processor type and speed</title>
<formalpara id="pmmx">
<title>Intel x86 (32-bit)</title>
<para>You will need at least <emphasis>a Pentium or Celeron compatible CPU, with MMX extensions</emphasis>.
<para>You will need at least <emphasis role="bold">a Pentium or Celeron compatible CPU, with MMX extensions</emphasis>.
This includes most AMD (K5+), Transmeta, VIA, and other x86-compatible CPUs.
A processor speed of <emphasis>at least 500 MHz</emphasis> is highly recommended for running interactive desktop applications; lower speed may be usable in text-only or server modes.</para>
A processor speed of <emphasis role="bold">at least 500 MHz</emphasis> is highly recommended for running interactive desktop applications; lower speed may be usable in text-only or server modes.</para>
</formalpara>
<formalpara id="x86_64">
<title>Intel x86_64 (64-bit)</title>
......@@ -19,9 +19,9 @@
</formalpara>
<formalpara id="ppc">
<title>PowerPC (32-bit)</title>
<para>You will need at least <emphasis>a G3 or later</emphasis> CPU.
<para>You will need at least <emphasis role="bold">a G3 or later</emphasis> CPU.
The 603 CPU is not supported by this version of Adélie Linux.
A processor speed of <emphasis>at least 600 MHz</emphasis> is highly recommended for running interactive desktop applications, but all G3 and G4 CPUs are supported.
A processor speed of <emphasis role="bold">at least 600 MHz</emphasis> is highly recommended for running interactive desktop applications, but all G3 and G4 CPUs are supported.
AltiVec/VMX is not required to run Adélie; however, software titles are increasingly taking advantage of processors with these extensions.</para>
</formalpara>
<formalpara id="ppc64">
......@@ -33,10 +33,61 @@
<para>All 64-bit ARM processors are supported by the Adélie Linux system; however, some SoCs may need a custom kernel. For more information, see the AArch64 HCL<!-- TODO XXX !! -->.</para>
</formalpara>
</section>
<section>
<title>Hardware</title>
<para>At least 384 MB RAM is required for the Standard installation of Adélie Linux, and at least 512 MB RAM is highly recommended if you plan to run larger applications like Firefox and Thunderbird. At least 40 MB RAM is required to install the server version of Adélie Linux.</para>
<warning><title>Warning</title><para>Using less than 40 MB RAM may cause lock ups or crashes during package installation.</para></warning>
<para>At least 3 GB of disk space is required for a full desktop installation of Adélie Linux. The base, text-only installation of Adélie Linux requires about 300 MB of disk space, not counting additional packages and your data. It is recommended that you have at least 1 GB of disk space for most server roles.</para>
<section id="ram_disk">
<title>Memory and disk space</title>
<para>Memory and disk space requirements depend on the edition of Adélie Linux you wish to use.</para>
<table frame="all">
<title>Minimum and recommended memory and disk space</title>
<tgroup cols="8" align="left" colsep="1" rowsep="1">
<colspec colname="dimension"/>
<colspec colname="min_min"/>
<colspec colname="min_rec"/>
<colspec colname="compact_min"/>
<colspec colname="compact_rec"/>
<colspec colname="std_min"/>
<colspec colname="std_rec"/>
<colspec colname="full_min"/>
<colspec colname="full_rec"/>
<thead>
<row>
<entry namest="min_min" nameend="min_rec" align="center">Text-Only</entry>
<entry namest="compact_min" nameend="compact_rec" align="center">Compact</entry>
<entry namest="std_min" nameend="std_rec" align="center">Standard</entry>
<entry namest="full_min" nameend="full_rec" align="center">Full</entry>
</row>
<row>
<entry namest="min_min">Minimum</entry><entry>Recommended</entry>
<entry>Minimum</entry><entry>Recommended</entry>
<entry>Minimum</entry><entry>Recommended</entry>
<entry>Minimum</entry><entry>Recommended</entry>
</row>
</thead>
<tbody>
<row>
<entry>Memory</entry>
<entry>64 MB</entry>
<entry>96 MB</entry>
<entry>192 MB</entry>
<entry>256 MB</entry>
<entry>384 MB</entry>
<entry>1 GB</entry>
<entry>512 MB</entry>
<entry>2 GB</entry>
</row>
<row>
<entry>Disk space</entry>
<entry>350 MB</entry>
<entry>512 MB</entry>
<entry>1.5 GB</entry>
<entry>2 GB</entry>
<entry>4 GB</entry>
<entry>6 GB</entry>
<entry>6 GB</entry>
<entry>10 GB</entry>
</row>
</tbody>
</tgroup>
</table>
<warning><title>Warning</title><para>Using less than 96 MB RAM may cause lock ups or crashes during package installation. For systems with less than 96 MB RAM, it is highly recommended that you use the HorizonScript Executor in Target Mode on a computer with more than 96 MB RAM. For more information, see the section on Target Mode.</para></warning>
</section>
</chapter>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment