system/perl: upgrade provided Getopt::Long to 2.51

parent fdd88d78
......@@ -15,7 +15,9 @@ license="Artistic-1.0-Perl GPL-2.0"
depends=""
makedepends="bzip2-dev zlib-dev"
subpackages="$pkgname-doc $pkgname-dev"
# XXX - Remove Getopt::Long when upgrading to 5.32+
source="https://www.cpan.org/src/5.0/perl-$pkgver.tar.gz
https://cpan.metacpan.org/authors/id/J/JV/JV/Getopt-Long-2.51.tar.gz
"
# secfixes:
......@@ -46,6 +48,8 @@ prepare() {
rm -rf cpan/Compress-Raw-Bzip2/bzip2-src
sed -i '/\(bzip2\|zlib\)-src/d' MANIFEST
rm -rf cpan/Getopt-Long && mv "$srcdir"/Getopt-Long-2.51 cpan/Getopt-Long
rm cpan/Getopt-Long/Makefile.PL
}
build() {
......@@ -112,4 +116,5 @@ dev() {
default_dev
}
sha512sums="03914ed51163c998a6afa45610a13cf50124a2c68d291c344b0d52fa15c27fc5d5d4f5dc117516078a03dfd51250097b87c8d5e2b17c7858a4c8c536aecd05af perl-5.26.3.tar.gz"
sha512sums="03914ed51163c998a6afa45610a13cf50124a2c68d291c344b0d52fa15c27fc5d5d4f5dc117516078a03dfd51250097b87c8d5e2b17c7858a4c8c536aecd05af perl-5.26.3.tar.gz
e70b2c30f5f85d7bf387381782a22b55f76598e1b4e19102fbf463c4333e91090ad2da49965be6211821d4f7f109aa7e4153348a9142f38fdb1a39299c997c02 Getopt-Long-2.51.tar.gz"
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment